Samba ha rilasciato la versione 4.1.3 che va solo a correggere bug di sicurezza; in particolare il CVE-2013-4408 (DCE-RPC fragment length field is incorrectly checked) e il CVE-2012-6150 (pam_winbind login without require_membership_of restrictions).
Samba versions 3.4.0 and above (versions 3.4.0 – 3.4.17, 3.5.0 –
3.5.22, 3.6.0 – 3.6.21, 4.0.0 – 4.0.12 and including 4.1.2) are
vulnerable to buffer overrun exploits in the client processing of
DCE-RPC packets. This is due to incorrect checking of the DCE-RPC
fragment length in the client code.
This is a critical vulnerability as the DCE-RPC client code is part of
the winbindd authentication and identity mapping daemon, which is
commonly configured as part of many server installations (when joined
to an Active Directory Domain). A malicious Active Directory Domain
Controller or man-in-the-middle attacker impersonating an Active
Directory Domain Controller could achieve root-level access by
compromising the winbindd process.
Samba server versions 3.4.0 – 3.4.17 and versions 3.5.0 – 3.5.22 are
also vulnerable to a denial of service attack (server crash) due to a
similar error in the server code of those versions.
Samba server versions 3.6.0 and above (including all 3.6.x versions,
all 4.0.x versions and 4.1.x) are not vulnerable to this problem.
In addition range checks were missing on arguments returned from calls
to the DCE-RPC functions LookupSids (lsa and samr), LookupNames (lsa and samr)
and LookupRids (samr) which could also cause similar problems.
As this was found during an internal audit of the Samba code there are
no currently known exploits for this problem (as of December 9th 2013).
Winbind allows for the further restriction of authenticated PAM logins using
the require_membership_of parameter. System administrators may specify a list
of SIDs or groups for which an authenticated user must be a member of. If an
authenticated user does not belong to any of the entries, then login should
fail. Invalid group name entries are ignored.
Samba versions 3.3.10, 3.4.3, 3.5.0 and later incorrectly allow login from
authenticated users if the require_membership_of parameter specifies only
invalid group names.
This is a vulnerability with low impact. All require_membership_of group
names must be invalid for this bug to be encountered.